use strict;
my $str = 'switch (new Date().getDay()) {
case 0:
day = "Sunday";
break;
case 1:
day = "Monday";
break;
case 2:
day = "Tuesday";
break;
case 3:
day = "Wednesday";
break;
case 4:
day = "Thursday";
break;
case 5:
day = "Friday";
break;
case 6:
day = "Saturday";
break;
}';
my $regex = qr/^(\s*)case\s+([^:]*?)\s*:(.*?)\s*break;?/msp;
my $subst = '$1$2 -> {$3\\n$1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";