package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)^(\s*)case\s+([^:]*?)\s*:(.*?)\s*break;?`)
var str = `switch (new Date().getDay()) {
case 0:
day = "Sunday";
break;
case 1:
day = "Monday";
break;
case 2:
day = "Tuesday";
break;
case 3:
day = "Wednesday";
break;
case 4:
day = "Thursday";
break;
case 5:
day = "Friday";
break;
case 6:
day = "Saturday";
break;
}`
var substitution = "$1$2 -> {$3\n$1}"
fmt.Println(re.ReplaceAllString(str, substitution))
}