#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = " {2}|\r\n|&(?!(#\d+|\w+);)|[<>\r\n'"`]"
Local $sString = " {2}|\r\n|[&(?!(#\\d+|\\w+);)<>\r\n'"`]" & @CRLF & _
"" & @CRLF & _
"&&& ' ; "< >" & @CRLF & _
" "http://www.example.com/?a=1&b=2&c=3/"," & @CRLF & _
" "Three in a row: &&&"," & @CRLF & _
" "< is <, > is >, ' is ', etc." handle numeric escapes, e.g.   – Jake Cobb Aug 3 '16 at 19:55 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")