import Foundation
let pattern = ##" {2}|\r\n|&(?!(#\d+|\w+);)|[<>\r\n'"`]"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
{2}|\r\n|[&(?!(#\\d+|\\w+);)<>\r\n'"`]
&&& ' ; "< >
"http://www.example.com/?a=1&b=2&c=3/",
"Three in a row: &&&",
"< is <, > is >, ' is ', etc." handle numeric escapes, e.g.   – Jake Cobb Aug 3 '16 at 19:55
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)