import re
regex = re.compile(r" {2}|\r\n|&(?!(#\d+|\w+);)|[<>\r\n'\"`]")
test_str = (" {2}|\\r\\n|[&(?!(#\\\\d+|\\\\w+);)<>\\r\\n'\"`]\n\n"
"&&& ' ; \"< >\n"
" \"http://www.example.com/?a=1&b=2&c=3/\",\n"
" \"Three in a row: &&&\",\n"
" \"< is <, > is >, ' is ', etc.\" handle numeric escapes, e.g.   – Jake Cobb Aug 3 '16 at 19:55 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")