import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " {2}|\\r\\n|&(?!(#\\d+|\\w+);)|[<>\\r\\n'\"`]";
final String string = " {2}|\\r\\n|[&(?!(#\\\\d+|\\\\w+);)<>\\r\\n'\"`]\n\n"
+ "&&& ' ; \"< >\n"
+ " \"http://www.example.com/?a=1&b=2&c=3/\",\n"
+ " \"Three in a row: &&&\",\n"
+ " \"< is <, > is >, ' is ', etc.\" handle numeric escapes, e.g.   – Jake Cobb Aug 3 '16 at 19:55 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}