#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a href="(?:(?!<a href="|<\/a>).)*(?:たこ|いか|ししゃも)<\/a>"
Local $sString = "今日はお寿司を食べに来た。僕の好きな寿司<a href="tako.html">ネタはたこ</a>と<a href="ika.html">スルメいか</a>です。実は <a href="kihada-maguro.html">きはだまぐろ</a>も好きですが、<a href="shishamo.html">珍しいししゃも</a>も食べてみたいです。"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")