import Foundation
let pattern = #"<a href="(?:(?!<a href="|<\/a>).)*(?:たこ|いか|ししゃも)<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"今日はお寿司を食べに来た。僕の好きな寿司<a href="tako.html">ネタはたこ</a>と<a href="ika.html">スルメいか</a>です。実は <a href="kihada-maguro.html">きはだまぐろ</a>も好きですが、<a href="shishamo.html">珍しいししゃも</a>も食べてみたいです。"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)