use strict;
my $str = '今日はお寿司を食べに来た。僕の好きな寿司<a href="tako.html">ネタはたこ</a>と<a href="ika.html">スルメいか</a>です。実は <a href="kihada-maguro.html">きはだまぐろ</a>も好きですが、<a href="shishamo.html">珍しいししゃも</a>も食べてみたいです。';
my $regex = qr/<a href="(?:(?!<a href="|<\/a>).)*(?:たこ|いか|ししゃも)<\/a>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}