re = /<a href="(?:(?!<a href="|<\/a>).)*(?:たこ|いか|ししゃも)<\/a>/m
str = '今日はお寿司を食べに来た。僕の好きな寿司<a href="tako.html">ネタはたこ</a>と<a href="ika.html">スルメいか</a>です。実は <a href="kihada-maguro.html">きはだまぐろ</a>も好きですが、<a href="shishamo.html">珍しいししゃも</a>も食べてみたいです。'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end