# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a href=\"(?:(?!<a href=\"|<\/a>).)*(?:たこ|いか|ししゃも)<\/a>"
test_str = "今日はお寿司を食べに来た。僕の好きな寿司<a href=\"tako.html\">ネタはたこ</a>と<a href=\"ika.html\">スルメいか</a>です。実は <a href=\"kihada-maguro.html\">きはだまぐろ</a>も好きですが、<a href=\"shishamo.html\">珍しいししゃも</a>も食べてみたいです。"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.