# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\s\S]*(?:location="([^"]*)")[\s\S]*/$1/gm;t' <<< "<xxxx location=\"file path/level1/level1\" xxxx some=\"xxx\">
<xxxx location=\"file path/level1/level2\" xxxx some=\"xxx\">
<xxxx location=\"file path/level1/level3\" xxxx some=\"xxx\">"