use strict;
my $str = '<xxxx location="file path/level1/level1" xxxx some="xxx">
<xxxx location="file path/level1/level2" xxxx some="xxx">
<xxxx location="file path/level1/level3" xxxx some="xxx">';
my $regex = qr/[\s\S]*(?:location="([^"]*)")[\s\S]*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";