package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\s\S]*(?:location="([^"]*)")[\s\S]*`)
var str = `<xxxx location="file path/level1/level1" xxxx some="xxx">
<xxxx location="file path/level1/level2" xxxx some="xxx">
<xxxx location="file path/level1/level3" xxxx some="xxx">`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}