$re = '/[\s\S]*(?:location="([^"]*)")[\s\S]*/m';
$str = '<xxxx location="file path/level1/level1" xxxx some="xxx">
<xxxx location="file path/level1/level2" xxxx some="xxx">
<xxxx location="file path/level1/level3" xxxx some="xxx">';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;