// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[\s\S]*(?:location="([^"]*)")[\s\S]*"#).unwrap();
let string = "<xxxx location=\"file path/level1/level1\" xxxx some=\"xxx\">
<xxxx location=\"file path/level1/level2\" xxxx some=\"xxx\">
<xxxx location=\"file path/level1/level3\" xxxx some=\"xxx\">";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}