# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(src=")(?![^"]+\?)(?:[^"]+\\/|)/$1MyLocalPath\//gm;t' <<< "<ul class=\"reset smalltext\" id=\"msg_977743_extra_info\">
<li class=\"stars\"><img src=\"http://site123.com/forum/Themes/Curve_CC_css3/images/ranks/rank37.gif\" alt=\"*\" /></li>
<img src=\"http://site123.com/forum/Themes/Curve_CC_css3/images/useroff.gif\" alt=\"Offline\" />
src=\"http://site123.com/forum/index.php?PHPSESSID=0b057hm0efnc617b7463gs5ui4&action=dlattach;attach=5010;type=avatar\" alt=\"\" />"