re = /(src=")(?![^"]+\?)(?:[^"]+\/|)/m
str = '<ul class="reset smalltext" id="msg_977743_extra_info">
<li class="stars"><img src="http://site123.com/forum/Themes/Curve_CC_css3/images/ranks/rank37.gif" alt="*" /></li>
<img src="http://site123.com/forum/Themes/Curve_CC_css3/images/useroff.gif" alt="Offline" />
src="http://site123.com/forum/index.php?PHPSESSID=0b057hm0efnc617b7463gs5ui4&action=dlattach;attach=5010;type=avatar" alt="" />'
subst = '$1MyLocalPath/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result