#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(src=")(?![^"]+\?)(?:[^"]+\/|)"
Local $sString = "<ul class="reset smalltext" id="msg_977743_extra_info">" & @CRLF & _
"" & @CRLF & _
"<li class="stars"><img src="http://site123.com/forum/Themes/Curve_CC_css3/images/ranks/rank37.gif" alt="*" /></li>" & @CRLF & _
"" & @CRLF & _
"<img src="http://site123.com/forum/Themes/Curve_CC_css3/images/useroff.gif" alt="Offline" />" & @CRLF & _
"" & @CRLF & _
"src="http://site123.com/forum/index.php?PHPSESSID=0b057hm0efnc617b7463gs5ui4&action=dlattach;attach=5010;type=avatar" alt="" />"
Local $sSubst = "$1MyLocalPath/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)