# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(src=\")(?![^\"]+\?)(?:[^\"]+\/|)"
test_str = ("<ul class=\"reset smalltext\" id=\"msg_977743_extra_info\">\n\n"
"<li class=\"stars\"><img src=\"http://site123.com/forum/Themes/Curve_CC_css3/images/ranks/rank37.gif\" alt=\"*\" /></li>\n\n"
"<img src=\"http://site123.com/forum/Themes/Curve_CC_css3/images/useroff.gif\" alt=\"Offline\" />\n\n"
"src=\"http://site123.com/forum/index.php?PHPSESSID=0b057hm0efnc617b7463gs5ui4&action=dlattach;attach=5010;type=avatar\" alt=\"\" />")
subst = "$1MyLocalPath/"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.