import Foundation
let pattern = #"(src=")(?![^"]+\?)(?:[^"]+\/|)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<ul class="reset smalltext" id="msg_977743_extra_info">
<li class="stars"><img src="http://site123.com/forum/Themes/Curve_CC_css3/images/ranks/rank37.gif" alt="*" /></li>
<img src="http://site123.com/forum/Themes/Curve_CC_css3/images/useroff.gif" alt="Offline" />
src="http://site123.com/forum/index.php?PHPSESSID=0b057hm0efnc617b7463gs5ui4&action=dlattach;attach=5010;type=avatar" alt="" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1MyLocalPath/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)