# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[\*].+?SemprePresente1=(\d{2}\\/\d{4}).+?SemprePresente2=(\d{6})(?:(?!Opcional=)[^\*])+(Opcional=(\d+,\d+))?[^\*]+/\1;\2;\4\n/gms;t' <<< "********************
SemprePresente1=09/2019
SemprePresente2=987456
Um monte de coisas
Que não preciso
Opcional=698,00
Mais coisas que não preciso
********************
SemprePresente1=06/2019
SemprePresente2=123658
Um monte de coisas
Que não preciso
********************
SemprePresente1=09/2019
SemprePresente2=987699
Um monte de coisas
Opcional=9999,00
Mais coisas que não preciso"