$re = '/^[\*].+?SemprePresente1=(\d{2}\/\d{4}).+?SemprePresente2=(\d{6})(?:(?!Opcional=)[^\*])+(Opcional=(\d+,\d+))?[^\*]+/ms';
$str = '********************
SemprePresente1=09/2019
SemprePresente2=987456
Um monte de coisas
Que não preciso
Opcional=698,00
Mais coisas que não preciso
********************
SemprePresente1=06/2019
SemprePresente2=123658
Um monte de coisas
Que não preciso
********************
SemprePresente1=09/2019
SemprePresente2=987699
Um monte de coisas
Opcional=9999,00
Mais coisas que não preciso';
$subst = "\1;\2;\4\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;