#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)^[\*].+?SemprePresente1=(\d{2}\/\d{4}).+?SemprePresente2=(\d{6})(?:(?!Opcional=)[^\*])+(Opcional=(\d+,\d+))?[^\*]+"
Local $sString = "********************" & @CRLF & _
"SemprePresente1=09/2019" & @CRLF & _
"SemprePresente2=987456" & @CRLF & _
"Um monte de coisas " & @CRLF & _
"Que não preciso" & @CRLF & _
"Opcional=698,00" & @CRLF & _
"Mais coisas que não preciso" & @CRLF & _
"********************" & @CRLF & _
"SemprePresente1=06/2019" & @CRLF & _
"SemprePresente2=123658" & @CRLF & _
"Um monte de coisas " & @CRLF & _
"Que não preciso" & @CRLF & _
"********************" & @CRLF & _
"SemprePresente1=09/2019" & @CRLF & _
"SemprePresente2=987699" & @CRLF & _
"Um monte de coisas" & @CRLF & _
"Opcional=9999,00" & @CRLF & _
"Mais coisas que não preciso"
Local $sSubst = "\1;\2;\4\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)