# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/( (\b\w{3}\b) )/$2/gm;t' <<< "the quick brown fox jumps over the lazy dog"