package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)( (\b\w{3}\b) )`)
var str = `the quick brown fox jumps over the lazy dog`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}