re = /( (\b\w{3}\b) )/m
str = 'the quick brown fox jumps over the lazy dog'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result