use strict;
my $str = 'the quick brown fox jumps over the lazy dog';
my $regex = qr/( (\b\w{3}\b) )/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";