#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^ " & @CRLF & _
"(?!" & @CRLF & _
" R" & @CRLF & _
" ( [0-9]{3,4} ) # (1)" & @CRLF & _
" - [a-zA-Z]{2,3} -" & @CRLF & _
" ( [0-9]{4,5} ) # (2)" & @CRLF & _
" $ " & @CRLF & _
")" & @CRLF & _
".+ "
Local $sString = "R788-COV-2040" & @CRLF & _
"R788-CgOV-2040" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")