package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mx)^
(?!
R
( [0-9]{3,4} ) # (1)
- [a-zA-Z]{2,3} -
( [0-9]{4,5} ) # (2)
$
)
.+ `)
var str = `R788-COV-2040
R788-CgOV-2040
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}