const regex = /^
(?!
R
( [0-9]{3,4} ) # (1)
- [a-zA-Z]{2,3} -
( [0-9]{4,5} ) # (2)
$
)
.+ /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
(?!
R
( [0-9]{3,4} ) # (1)
- [a-zA-Z]{2,3} -
( [0-9]{4,5} ) # (2)
$
)
.+ ', 'gm')
const str = `R788-COV-2040
R788-CgOV-2040
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}