$re = '/^
(?!
R
( [0-9]{3,4} ) # (1)
- [a-zA-Z]{2,3} -
( [0-9]{4,5} ) # (2)
$
)
.+ /mx';
$str = 'R788-COV-2040
R788-CgOV-2040
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);