import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ \n"
+ "(?!\n"
+ " R\n"
+ " ( [0-9]{3,4} ) # (1)\n"
+ " - [a-zA-Z]{2,3} -\n"
+ " ( [0-9]{4,5} ) # (2)\n"
+ " $ \n"
+ ")\n"
+ ".+ ";
final String string = "R788-COV-2040\n"
+ "R788-CgOV-2040\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}