using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^
(?!
R
( [0-9]{3,4} ) # (1)
- [a-zA-Z]{2,3} -
( [0-9]{4,5} ) # (2)
$
)
.+ ";
string input = @"R788-COV-2040
R788-CgOV-2040
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}