using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\#)(?<!\#\s)(?<!\w)parameter=[0-9]+";
string input = @"# default parameter
parameter=3
someparameter=3
a parameter=3
###parameter=3
# ## parameter=3
## # parameter=3
# parameter=3
# parameter=3
something something # parameter=3
parameter=3
#something parameter=3
# something parameter=3
parameter=#3
parameter=";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}