import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\#)(?<!\\#\\s)(?<!\\w)parameter=[0-9]+";
final String string = "# default parameter\n"
+ "parameter=3\n"
+ "someparameter=3\n"
+ "a parameter=3\n"
+ "###parameter=3\n"
+ "# ## parameter=3\n"
+ "## # parameter=3\n"
+ "# parameter=3\n"
+ "# parameter=3\n"
+ "something something # parameter=3\n"
+ " parameter=3\n"
+ "#something parameter=3\n"
+ "# something parameter=3\n"
+ "parameter=#3\n"
+ "parameter=";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}