re = /(?<!\#)(?<!\#\s)(?<!\w)parameter=[0-9]+/m
str = '# default parameter
parameter=3
someparameter=3
a parameter=3
###parameter=3
# ## parameter=3
## # parameter=3
# parameter=3
# parameter=3
something something # parameter=3
parameter=3
#something parameter=3
# something parameter=3
parameter=#3
parameter='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end