$re = '/(?<!\#)(?<!\#\s)(?<!\w)parameter=[0-9]+/m';
$str = '# default parameter
parameter=3
someparameter=3
a parameter=3
###parameter=3
# ## parameter=3
## # parameter=3
# parameter=3
# parameter=3
something something # parameter=3
parameter=3
#something parameter=3
# something parameter=3
parameter=#3
parameter=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);