using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-4] \w+ (?:[1-6]?[0-9]|7[0-2]) (?:[1-9]?[0-9]|100) [0-1] [0-1] [0-1] \d+$";
string input = @"1 Model 42 18 1 0 1 1200";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}