$re = '/^[0-4] \w+ (?:[1-6]?[0-9]|7[0-2]) (?:[1-9]?[0-9]|100) [0-1] [0-1] [0-1] \d+$/m';
$str = '1 Model 42 18 1 0 1 1200';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);