re = /^[0-4] \w+ (?:[1-6]?[0-9]|7[0-2]) (?:[1-9]?[0-9]|100) [0-1] [0-1] [0-1] \d+$/m
str = '1 Model 42 18 1 0 1 1200'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end