import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-4] \\w+ (?:[1-6]?[0-9]|7[0-2]) (?:[1-9]?[0-9]|100) [0-1] [0-1] [0-1] \\d+$";
final String string = "1 Model 42 18 1 0 1 1200";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}