package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-4] \w+ (?:[1-6]?[0-9]|7[0-2]) (?:[1-9]?[0-9]|100) [0-1] [0-1] [0-1] \d+$`)
var str = `1 Model 42 18 1 0 1 1200`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}