use strict;
my $str = '1 Model 42 18 1 0 1 1200';
my $regex = qr/^[0-4] \w+ (?:[1-6]?[0-9]|7[0-2]) (?:[1-9]?[0-9]|100) [0-1] [0-1] [0-1] \d+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}