#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[+-]?((\d+(\.\d+)?)|(\.\d+))$"
Local $sString = "0.00000" & @CRLF & _
"0.00" & @CRLF & _
"-200" & @CRLF & _
"+200" & @CRLF & _
"200" & @CRLF & _
"200.2" & @CRLF & _
"-200.2" & @CRLF & _
"+200.2" & @CRLF & _
".000" & @CRLF & _
".1" & @CRLF & _
".2" & @CRLF & _
"3." & @CRLF & _
"."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")