package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?((\d+(\.\d+)?)|(\.\d+))$`)
var str = `0.00000
0.00
-200
+200
200
200.2
-200.2
+200.2
.000
.1
.2
3.
.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}