re = /^[+-]?((\d+(\.\d+)?)|(\.\d+))$/m
str = '0.00000
0.00
-200
+200
200
200.2
-200.2
+200.2
.000
.1
.2
3.
.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end