// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[+-]?((\d+(\.\d+)?)|(\.\d+))$").unwrap();
let string = "0.00000
0.00
-200
+200
200
200.2
-200.2
+200.2
.000
.1
.2
3.
.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}