using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[+-]?((\d+(\.\d+)?)|(\.\d+))$";
string input = @"0.00000
0.00
-200
+200
200
200.2
-200.2
+200.2
.000
.1
.2
3.
.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}