using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<iframe[^<>]*\bdata-context\b[^<>]*>[\s\S]*?<\/iframe>";
string input = @"<iframe src=""http://youtube.com""></iframe>
<iframe data-context=""whatever"" src=""http://youtube.com""></iframe>
<iframe src=""http://youtube.com""></iframe> <iframe src=""http://youtube.com""></iframe>
<p>Potatoes are good</p>
<iframe src=""http://youtube.com""></iframe>
<iframe src=""http://youtube.com"" data-context=""whatever""></iframe>
<iframe src=""http://youtube.com""></iframe>
<iframe src=""http://instagram.com""></iframe> ";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}